Tuesday, December 06, 2005

VMware-authd.exe slowing down my PC

I was doing some work on one of my PC's and I had the processes list open in Task Manager. Out of the corner of my eye, I noticed that one process, VMware-authd.exe, was going from 0 to 10% of the CPU. I didn't know what that process did, I went out on a limb and assumed that it was somehow related to VMWare. VMware is one of my favorite tools, but I wasn't running any VMWare sessions. Time to go Googling. Apparently it's a service that provides administrator priviledges to to a running VMWare session if the host use isn't logged in with administrator access rights

If you are logged in with admin rights, you don't need to have this service running. VMware-authd.exe is the name of the executable for the "VMware Authorization Service" service. You can go into Services and shut that service down and then set it's startup type to "manual". There are no other services that depend on that service to be running. You can also stop the service from the Windows command line with the following:

net stop VMAuthdService

[Edited on 3/5/08]

If you need to restart the service from the command line, use the following:

net start VMAuthdService

40 comments:

  1. Thanks Christopher!
    I have been looking everywhere for an answer to that problem.

    ReplyDelete
  2. Nice post Chirs!
    It was wasting nearly 20 MB of my memory for nothing.
    -Thanks

    ReplyDelete
  3. Justin Deltener10/17/2006 11:52 AM

    Thanks bud, I just googled this for exactly the same reason. On my 2ghz laptop its spiking to 20%+ every other second doh!

    ReplyDelete
  4. thanks, the other culprits are vmnetdhcp and vmnat .. i've put them into manual mode in the component services console.

    ReplyDelete
  5. Thanks Chris,

    I'd been meaningto find out what this was for ages. Sorted now.

    Cheers

    Ian

    ReplyDelete
  6. Great post! It saved my day!

    Thanks a lot,

    Mike

    ReplyDelete
  7. Excellent - Process Explorer pointed me in the right direction, and your post confirmed the culprit

    Thanks!

    ReplyDelete
  8. Excellent post - many thanks. Solved my problem immediately.

    ReplyDelete
  9. Thank you for a get post
    I was considering unistalling this piece of software perhaps I can use it as needed with the baggage.

    ReplyDelete
  10. Thanks! It was slowing down my boot up by blocking the network for 30-45 seconds!
    I also stopped vmount2 (ws 6) which will start anyway when you mount a virtual disk.

    ReplyDelete
  11. Excellent advice. I watched my CPU usage bounce around endlessly on an idle machine, with this process going from 0-50%. It's ridiculous when software manufacturers burden machines with useless tasks that consume CPU without your knowledge.

    I often use VMware as an example of some of the coolest and best software I have seen, but this is a black mark on their name.

    ReplyDelete
  12. Echo the thanks! I hate non-essential processes. Why can't they start when I run vm-ware, which is about once a month - maybe...

    ReplyDelete
  13. Thx, you saved my day! After deactivating the "VMware Authorization Service" my computer boots really faster than before.

    ReplyDelete
  14. I'm glad Google pointed me to your blog. Finally my XP boot-time delay is gone. Thank u very much!

    Greets Ramon

    ReplyDelete
  15. I agree that companies arrogantly take over our computers with useless services because their software is "so important". Bugs the hell out of me.

    Anyway, thanks for this post!

    ReplyDelete
  16. Nice job Chris, this speed up my machine.
    Thanks

    ReplyDelete
  17. Thanks a lot! Especially for the "net stop VMAuthdService" hint. By the way: "net start VMAuthdService" restarts the service.

    ReplyDelete
  18. Hi
    RAM usage isnt really that big of a deal for this process... CPU usage has been near 0 for me too (CPU time total is more important also)

    What none of you pointed out is that this process issues massive number of page faults even when no VM is running! That's much more expensive than RAM or CPU usage in my opinion because each page fault correspond to a disk access!!!

    ReplyDelete
  19. I would be very surprised if many of the page faults require disk access (ie. hard page faults) these are undoubtedly soft page faults due to shared memory.

    ReplyDelete
  20. Thank you! Great Job!

    greetings
    Paolo

    ReplyDelete
  21. Thanks very much - same problem!
    Phil

    ReplyDelete
  22. Thanks too... I remember that this problem didn't happened on early versions... It's nonsense that they continue to be so stubborn with these services...

    ReplyDelete
  23. Thanks for the tip! Unfortunately it seems the VMWare Server, at least starting from 1.0.2, needs this Authd service for some registration service and without that registration service you can't login to VMWare...

    ReplyDelete
  24. Awesome, thank you! The regular CPU spikes up to 40% have now gone!

    ReplyDelete
  25. When I tried :net stop VMAuthdService
    I got the message:
    The following services are dependent on the VMware Authorization Service service
    .
    Stopping the VMware Authorization Service service will also stop these services.


    VMware Registration Service

    Do you want to continue this operation? (Y/N) [N]:

    I said 'N'

    ReplyDelete
  26. Thanks Chris - you're a star!

    The best tip I've found on teh intertubes for ages. ;)

    ReplyDelete
  27. This comment has been removed by the author.

    ReplyDelete
  28. Thank you very much! you saved my energy savings!!

    Now remains the problem of VMnetDHCP..
    doesn't seems to work if started manually

    ReplyDelete
  29. Stopping this service killed the web interface used to manange the VMs on the host. Can the interface run without the service?

    ReplyDelete
  30. I've written a script + instructions which let you automatically start the VMware background services when you launch VMware and then stop them when you close it down:

    http://www.pretentiousname.com/vmware_launcher/index.html

    Hope it's useful to someone else. I wish VMware would have done this themselves but it's been this way for years so I guess that's unlikely.

    ReplyDelete
  31. Indeed awesome! thank you!

    ReplyDelete
  32. This solved my annoying 100% CPU peak every few seconds. Still great!

    ReplyDelete
  33. Wow this is a very great tip. This was killing my whole CPU.

    ReplyDelete
  34. Спасибо!

    ReplyDelete
  35. Thanks. WMware player seems to work fine without it.

    ReplyDelete
  36. thats service took 100% cpu once for me making my server extremly slow, even that i have 12 Core CPU!!!!

    something is broken with that shiit

    ReplyDelete

Note: Only a member of this blog may post a comment.