Tuesday, January 29, 2008

When the clipboard doesn't work across Remote Desktop

Every now and then, when I have a remote desktop connection open, the clipboard fails to copy across the sessions.  It's usually the remote to local copy that's borked.  It's pretty easy to fix, but I can never remember what I need to do to fix the connection.

Fortunately the Terminal Services Team Blog has got that covered.  Just kill and restart the rdpclip process in the remote session.   There was also a part two to that post that was pretty interesting.

[Edited on 1/30/08]
There is a command line way of resetting rdpclip, so you can roll up both steps as a batch file

taskkill /IM rdpclip.exe



  1. this does not fix the issue.

  2. @Anonymous,

    It usually worked for me, but that problem occurred over three years ago. You might want to reach out to the guys at the Terminal Services Team Blog.

  3. Solved my problem. Thanks.

  4. That fixed it for me! I was able to copy text, but not images. Now everything copies/pastes as expected. Thanks for posting this fix!


Note: Only a member of this blog may post a comment.